Sorry, you need to enable JavaScript to visit this website.

You are here

Arduino MKR NB 1500 does not connect

6 posts / 0 new
Last post

Paul's picture
by Paul

Arduino MKR NB 1500 does not connect
Hi Telstra Dev team,   I have difficult to get my 1500 to work, please help.   Some info:
  • Arduino IDE: 1.8.9
  • Windows 10
  • Location: Doncaster East, 3109
  • SIM ICCID: *9629 (activated on 15 Apr)
  What I did:
  1. Followed the blog
  2. Antenna plugged in
  3. Installed libs
  4. Tried both catm1_hello_arduino.ino and catm1_hello_mosquitto.ino, but none of them works
  5. "" seems offline by the time of my test, so changed mqttBroker in the source code to "" (
  6. Re-compile and tried both examples again, but still shows "Not connected" or stucks at "Warming up...."
​Can I ask:
  • Do I need to create Apps and keys at
  • Did I miss something?
  • How to debug this connection? Currently, the Arduino code is very high level and not easy to debug. I hope you can provide some debugging examples.
  • Is there anything else I can do to resolve the issue?
  Thanks a lot!   Cheers, Paul            

David's picture
by David

Troubleshooting connectivity issues on your MKR NB 1500

Hi Paul, Sorry to hear you're having connectivity issues. For troubleshooting there's a couple of paths you can take;

For basic connectivity diagnosis, you can try and use the Connected Things API to do some basic high-level connectivity testing. To find you keys;

  1. Log into TelstraDev.
  2. Switch the your Company Profile (under your name).
  3. Then find your keys under My Apps and Keys.
  4. There’s a Postman collection here for quick access in using the API

For trouble-shooting on the board itself, if you run the following sketches in order it may be able to pinpoint the exact issue.

1.            TestModem – Will test the modem, does not require a SIM card

2.            NBScanNetworks – Tests network/radio and SIM card

3.            NBSSLWebclient – Tests data access

thanks, David

Paul's picture
by Paul

Hi David,

Hi David,

Sim card is ok, I checked Connected Things API.

I tested the board, here is the result:

1. Tested TestModem, 2/5 failure. Not very stable, but the modem seems working.

Screen record:

2. Tested NBScanNetworks, tried 5 times and no responding at all

Screen record:

3. NBSSLWebclient is not tested

Still cannot connect to the network, need your support.



Cameron's picture
by Cameron

Arduino MKR NB 1500 does not connect

Hi David,

I'm having the same trouble as Paul.

I'm running windows ten and Arduino IDE.

When I run the Test Modem Sketch I get:
"Starting modem test...modem.begin() succeeded
Checking IMEI...Error: Could not get IMEI"

When I run the Choose RAT sketch it seems to allow me to choose NB:

"Please choose your Radio Access Technology:

0 - CAT M1 only
1 - NB IoT only
2 - CAT M1 preferred, NB IoT as failover (default)
3 - NB IoT preferred, CAT M1 as failover

> 1
Disconnecting from network: done.
Setting Radio Access Technology: done.
Applying changes and saving configuration: done.

Radio Access Technology selected.
Now you can upload your 4G application sketch."

When I run the NB Scan Networks Sketch I get:

"NB IoT/LTE Cat M1 networks scanner
Not connected
Not connected
Not connected
Not connected
Not connected
Not connected
Not connected"

I'v found others having the same problems here:

When I run the PIN management sketch it says:

"No pin necessary.
Checking register in NB IoT / LTE Cat M1 network...ERROR"

I can run basic sketches OK that don't use the modem and monitor them on the serial monitor but none that need the modem.

I've been able to do the connecting an MKR NB 1500 to Azure Hub sketch but then can't comunicate with it.

I havent had any luck using the telstra API hub to create tokens and check sims etc.

Some more detailed instructions on this would be much apreciated.

Any ideas would be great.



Gino's picture
by Gino

We had the same problems as you
Hi Paul, we had the same problems as you. In our case there were two issues: 1) The weird freezing issues for us seem to be caused by the fact that the modem on the board seems to have a high instantaneous current draw, and so the voltage from most USB ports droops and freezes the modem. Out of three computers so far, we have only found one USB port that can run the MKR NB 1500. But it works perfectly on the good port. Never works on any others.  The simplest test for this is to use the modem read IMEI test as David suggested. That doesn't need the sim card plugged in. If you can read the IMEI consistently without failure, you have a USB port that can support the board. If it doesn't work, or only works once every few times, the USB port can't power the board. Fortunately you can plug a lipo battery backup into the board, and that will smooth out the current draw and the board will run OK. With the battery backup, you should be able to use any USB port. Note that you also should use the "good" USB port, or the battery backup when flashing the board, and it seems that the high modem current draw can happen at any time and also corrupt the flash. 2) Sims weren't actually activated by Telstra until we called support. You can check sim activation status via the postman API "Search SIMS" command as David suggested. If your sim doesn't show there, it isn't activated.

Bryan's picture
by Bryan

NB.begin behaviour?
  I have just received my MKR NB 1500. Test Modem seems to work ok and reports IMEI. The Scan program does not work because the NB.begin call never returns. Debug shows the +CEREG? command returns 0,0 repeatedly so it is not registered. The unit may not have signal because of poor reception in our area, but assumed (dangerous I know) that the program might report that. Is this correct behaviour? Thanks  
Log in or register to post comments